Latency Issue Related to Branded Environment

Incident Report for Edenred Pay

Resolved

The latency issue has been resolved, and the payment platform has resumed normal operations. Thank you for your patience during this time.
Posted Jan 27, 2026 - 14:33 EST

Investigating

Edenred Pay is investigating latency issues related to a branded instance of the payment platform.
Posted Jan 27, 2026 - 13:47 EST
This incident affected: White Labeled Environments.