Payment Activity

Incident Report for Edenred Pay

Resolved

This incident has been resolved, and the payment platform has resumed normal operations. Thank you for your patience during this time.
Posted Jul 06, 2026 - 10:09 EDT

Identified

Edenred Pay is implementing a solution that will allow payment data to display in reporting as expected. This process may take approximately 48 hours to complete due to the volume of data.
Posted Jul 01, 2026 - 14:15 EDT

Investigating

Edenred Pay is investigating an issue that is preventing the Payment Activity report from displaying all applicable payment data. We will continue to provide updates as more information becomes available. Thank you for your patience as we work to resolve this issue.
Posted Jul 01, 2026 - 10:12 EDT
This incident affected: Edenred Pay Payment Platform.