Account Statements in Payment Platform

Incident Report for Edenred Pay

Resolved

Edenred Pay has implemented a solution for this event. Account statements can now begin to process.
Posted Jul 08, 2025 - 19:06 EDT

Identified

Edenred Pay has identified the issue. Account Statements should display in the user interface following the update that is planned to occur on Tuesday, July 8, 2025.
Posted Jul 07, 2025 - 13:45 EDT

Investigating

Account Statements are not populating as expected in the user interface of the payment automation platform. Edenred Pay is actively investigating this issue.
Posted Jul 07, 2025 - 11:05 EDT
This incident affected: Edenred Pay Payment Platform.