Batches Without Payments

Incident Report for Edenred Pay

Resolved

All affected batches have been republished successfully. This incident is now resolved. Thank you for your patience during this time.
Posted Jul 01, 2026 - 17:09 EDT

Identified

Edenred Pay has identified the issue and a fix is being implemented.
Posted Jul 01, 2026 - 15:53 EDT

Investigating

Edenred Pay is investigating an issue that is allowing batch creation without associated payments. We will provide updates as information becomes available.
Posted Jul 01, 2026 - 14:27 EDT
This incident affected: Edenred Pay Payment Platform.