Outdated Data in Reporting

Incident Report for Edenred Pay

Resolved

Edenred Pay implemented a solution that has resolved this incident.
Posted Aug 25, 2026 - 07:58 EDT

Investigating

Edenred Pay is currently investigating an issue with our external reporting platform that is causing some reports to display incorrect data. Our team is working diligently to resolve the issue as quickly as possible.
Posted Aug 24, 2026 - 10:19 EDT
This incident affected: Edenred Pay Payment Platform.