Payee Portal Payment Data

Incident Report for Edenred Pay

Monitoring

A fix has been implemented and payments are now beginning to appear in the Payee Portal as expected. We are continuing to monitor results and will provide an update once this incident is resolved.
Posted Jul 11, 2026 - 17:52 EDT

Update

Edenred Pay is actively working to restore payment data to the Payee Portal. We apologize for any inconvenience and appreciate your continued patience as we resolve this issue. We will provide updates as more information becomes available.
Posted Jul 10, 2026 - 17:11 EDT

Identified

Edenred Pay has identified an issue that is preventing payment data from displaying in the Payee Portal as expected. We are implementing a solution that should allow payments to become available in the portal by the end of the business day.
Posted Jul 10, 2026 - 10:50 EDT
This incident affects: Edenred Pay Payment Platform.